Configuracion de SSID AP Autonomo CISCO

AP cisco.png

Esta configuración fue realizada hace varios en mi laboratorio. Esta completamente funcional y es la que tengo actualmente operando en la compañía.

 

 

Router Wifi
Topología básica para AP Autónomo.

 

Configuración AP

hostname AP1
!
!
logging rate-limit console 9
enable secret 5 XXXXXXXXXXXX
!
no aaa new-model
no ip source-route
no ip cef
ip domain name LAB_INALAMBRICA
!
!
dot11 syslog
dot11 vlan-name Gestion vlan 99
dot11 vlan-name Lab_Inalambrica vlan 109

Configuración de SSID y Vlan
dot11 ssid LAB_INALAMBRICA
vlan 109
authentication open
authentication key-management wpa version 2
guest-mode
mbssid guest-mode
wpa-psk ascii 7 XXXXXXXX

Configurando el Radio y la Interface Ethernet.

interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 109 mode ciphers aes-ccm   (Encriptación y asignación de Vlan a SSID)
!
ssid LAB_INALAMBRICA
!
antenna gain 0
stbc
channel 2437
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.109
encapsulation dot1Q 109
no ip proxy-arp
no ip route-cache
no cdp enable
bridge-group 109
bridge-group 109 subscriber-loop-control
bridge-group 109 spanning-disabled
bridge-group 109 block-unknown-source
no bridge-group 109 source-learning
no bridge-group 109 unicast-flooding
interface GigabitEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
!
interface GigabitEthernet0.99
encapsulation dot1Q 99 native
no ip redirects
ip directed-broadcast
no ip proxy-arp
no ip route-cache
no cdp enable
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface GigabitEthernet0.109
encapsulation dot1Q 109
no ip route-cache
bridge-group 109
bridge-group 109 spanning-disabled
no bridge-group 109 source-learning
!
interface GigabitEthernet1
no ip address
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning

Configuración de IP para Gestión
interface BVI1
ip address 192.168.1.2 255.255.255.0
ipv6 address dhcp
ipv6 address autoconfig
ipv6 enable
!
ip default-gateway 192.168.1.1
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip http help-path

bridge 1 route ip

line con 0
line vty 0 4
login local
transport input all
!
end

Configuración SW

interface GigabitEthernet1/0/37
description AP1

switchport trunk native vlan 99
switchport mode trunk

 

Comandos de Pruebas de configuración:

#sh ip in br

# sh dot11 associations

Algunos errores comunes en la configuración:

%DOT11-4-NO_SSID: No SSID configured. Dot11Radio0 not started

mbssid defined globally vs. locally

Configuración Pagina Oficial Aironet Access Points CISCO

Actualizacion de Software Wireless LAN Controller (WLC)

Pasos actualización WLC CISCO.

  1. Verificamos que tengamos conexión desde el PC a la WLC. Configuramos IP estaticas.
  2. Miramos direccionamientos en nuestro caso.

1

WLC

IP address: 172.16.X.253
Subnet mask: 255.255.255.0
Verificamos conectividad.

2

3. Ingresamos vía web a la WLC http//172.16.X.253

4. Verificamos versión de la WLC

3

5. Vamos a la página del fabricante y descargamos el IOS más actualizado.

https://software.cisco.com/download/navigator.html?mdfid=268437593

 

6. Nos conectamos directamente PC-WLC al puerto Management.

4

 

7. Ingresamos a la opción COMMANDS- Download File. Escribimos dirección del FTP, Path( Ubicación del Archivo) y el nombre del archivo.

5

 

8. Verificamos que la actualización del IOS fue exitosa.

 

6

 

Pasos en la pagina oficial de cisco.

http://www.cisco.com/c/en/us/support/docs/wireless-mobility/wireless-lan-wlan/68835-wlc-upgrade.html#anc0

Nota: Recuerden tener siempre encuenta primero antes de realizar cualquier cambio en el dispositivo realizar un backup de configuracion:):)

 

Administracion de Usuarios y Grupos en GNU/LINUX

tux

 

 

 

 

Los archivos que hacer parte del proceso de administracion de los usuarios en linux son:

ARCHIVO#/etc/passwd

Este es un archivo donde se guarda la informacion de los usuarios del sistema. Este asocia user,password,directorio,login de usuario con un userID. La sintaxis es la siguiente.

#cat /etc/passwd

alexalvarez0310:x:511:516::/home/alexalvarez0310:/bin/bash

usuario: password(RedHat no lo utliza por seguridad) :Idusuario :Idgrupo-primario :(GECOS)Comentario :Directorio-user :shell-de-inicio

ARCHIVO#/etc/shadow

En el archivo shadow se almacen las contraseñas de los usuarios de forma encriptada.

#cat /etc/shadow

tux

 

usuario: password-encryptado: lastchg ultima fecha de modificacion :cuando debe esperar para cambiar pass:cuando debe cambiar el pass :

ARCHIVO #/etc/group

Es donde se guarda la informacion de los grupos que se encuentran en el sistema.

# tail /etc/group

group

 

 

 

 

 

 

 

En este caso al grupo alumnos pertenecen el usuario1,usuario2

grupo : contraseña-del-grupo :numero-de-grupo : lista de usuarios que pertenecen al grupo segundario.

 

TIPOS DE USUARIOS.

1. USUARIO NORMAL:

  Es el que tiene la autorizacion de poder entrar en un sistema y poder trabajar con los recursos de este. estos pueden loguearsen en el sistema y crear directorios y archivos en el home que les pertenece.

– Suelen tener /bin/bash como shell de entrada.

– Sus UID es superior a 500

 

2. USUARIOS DEL SISTEMA:

Estos no representan personas si no partes de un sistema.

Ejemplos:

user

-Los usuarios del sistema normalmente no tienen shell de entrada /sbin/nologin

– Los directorios de home del usuario no estan hubicados en el home del sistema ej apache es /var/www

– Sus UID son del 1 -499

 

3. USUARIO ROOT.

Es comunmente denominado como el super usuario. su UID es el cero (0)

[root@localhost sysconfig]# cat /etc/passwd
root:x:0:0:root:/root:/bin/bash

– El root es el usuario principal del sistema, este es el que tiene los privilegios de crear usuarios, darles de alta. Es el usuario que se encarga de la configuracion y administracion de todo el sistema Linux.

-Tiene su directorio personal /root como directorio de inicio pero este usuario a diferencia d elos otros se puede loguear y puede crear editar eliminar ficheros en todo el sistema.

 

ADMINISTRACION DE USUARIOS.

Los usuarios pueden ser administrados de 2 formas. directamente sobre el archivo /etc/passwd  que no es muy practico y puede volverse algo complejo y engorroso o con los comandos de administracion de usuarios mas comunes useradd,usermod,userdel y las diferente combinaciones de opciones en linea de comandos.

 

– Agregando un nuevo usuario al sistema.

[root@localhost sysconfig]# adduser alexalvarez0310

– El usuario se agrega al /etc/passwd

– Se agrega la linea del suuario al /etc/shadow

– Crea automaticamente el home del usuario /home/alexalvarez0310

– Crea el archivo /etc/skel en el directorio del usuario (.bashrc,bash_profile)

– Crea un grupo privado para el usuario en el archivo /etc/group

 

-Agregando usuarios de forma un poco mas avanzada.

Diciendo a que grupo pertenecera donde sera la ubicacion de su directorio,tipo de shell.

[root@localhost home]# adduser -g usuarios -d/home/alexalvarez0310 -s /bin/bash -m -k /etc/skel alexalvarez0310

Entre las opciones del comando adduser que encontramos estan:

-d = Directorio del user

-s = Shell del user

-p Password

-g grupo primario del user

-G grupos a los que tambien pertenece el user

-m Se fuerza la creacion del directorio en su home

# Tambien podemos sacar la ayuda del comando con:

[root@localhost sysconfig]# adduser –help

[root@localhost sysconfig]#man  adduser

 

Cambiando el password del usuario.

[root@localhost sysconfig]# passwd alexalvarez0310
Changing password for user alexalvarez0310.
New password:
BAD PASSWORD: it is too simplistic/systematic
Retype new password:
passwd: all authentication tokens updated successfully.
– Eliminando usuario del sistema.

Se elimina usando el comando #userdell  si no conocemos bien las opciones agrgramos –help para que el sistema nos indique las opciones con su funcionamiento. En nuestro caso queremos eliminar el usuario alexalvarez0310  su home con todo su contenido.

#userdell  -r  alexalvarez0310

userdell

 

 

 

 

 

Modificando Usuarios en el sistema.

Para modificar usuarios ya creados en el sistema utilizaremos el comando #usermod

 

 

 

 

 

 

 

 

 

 

 

 

 

Comandos Administracion Basica Linux

consola

 

 

Aunque hay mucha variedad de comandos y sentencias para aplicarlos ire subiendo y explicando los mas basicos para administrar un sistema operativo linux.

 

comandos basicos Linux 1

  • [root@localhost prueba]# mpstat
    Linux 2.6.32-220.el6.i686 (localhost.localdomain)     07/16/2014     _i686_    (1 CPU)
    02:51:46 PM  CPU    %usr   %nice    %sys %iowait    %irq   %soft  %steal  %guest   %idle
    02:51:46 PM  all    2.56    0.00    1.28    0.06    0.04    0.08    0.00    0.00   95.97
  • [root@localhost prueba]# iostat
    Linux 2.6.32-220.el6.i686 (localhost.localdomain)     07/16/2014     _i686_    (1 CPU)avg-cpu:  %user   %nice %system %iowait  %steal   %idle
    2.34    0.53    2.33    0.14    0.00   94.66Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
    sda               6.64       288.88       135.42    1433820     672138
    sdb               0.06         0.60         0.00       2992          0
    scd0              0.01         0.08         0.00        404          0
  • [root@localhost prueba]# wc /etc/passwd
    32   48 1509 /etc/passwd
  • [root@localhost prueba]# sar -u 5
    Linux 2.6.32-220.el6.i686 (localhost.localdomain)     07/17/2014     _i686_    (1 CPU)10:46:29 PM     CPU     %user     %nice   %system   %iowait    %steal     %idle
    10:46:34 PM     all     10.06      0.00      1.81      0.00      0.00     88.13
    10:46:39 PM     all      1.80      0.00      0.60      0.00      0.00     97.60
  • [root@localhost prueba]# free
    total       used       free     shared    buffers     cached
    Mem:       2071268    1144768     926500          0      77360     778032
    -/+ buffers/cache:     289376    1781892
    Swap:      4109304          0    4109304
  • [root@localhost prueba]# ps aux
    USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
    root         1  0.0  0.0   2864  1400 ?        Ss   14:58   0:02 /sbin/init
    root         2  0.0  0.0      0     0 ?        S    14:58   0:00 [kthreadd]
    root         3  0.0  0.0      0     0 ?        S    14:58   0:00 [migration/0]
    root         4  0.0  0.0      0     0 ?        S    14:58   0:00 [ksoftirqd/0]
    root         5  0.0  0.0      0     0 ?        S    14:58   0:00 [migration/0]
    root         6  0.0  0.0      0     0 ?        S    14:58   0:00 [watchdog/0]
    root         7  0.0  0.0      0     0 ?        S    14:58   0:00 [events/0]
    root         8  0.0  0.0      0     0 ?        S    14:58   0:00 [cpuset]
    root         9  0.0  0.0      0     0 ?        S    14:58   0:00 [khelper]
    root        10  0.0  0.0      0     0 ?        S    14:58   0:00 [netns]
    root        11  0.0  0.0      0     0 ?        S    14:58   0:00 [async/mgr]
    root        12  0.0  0.0      0     0 ?        S    14:58   0:00 [pm]
    root        13  0.0  0.0      0     0 ?        S    14:58   0:00 [sync_supers]
  • [root@localhost prueba]# who
    prueba   tty1         2014-06-25 14:29 (:0)
    prueba   pts/0        2014-06-25 14:30 (:0.0)
  • [root@localhost prueba]# pwd
    /home/prueba

 

 

 

[root@localhost prueba]# watch vmstat -sSM
Every 2.0s: vmstat -sSM                                                  Fri Jul 18 13:11:55 2014

2071268  total memory
1163524  used memory
348864  active memory
671960  inactive memory

[root@localhost prueba]# free
total       used       free     shared    buffers     cached
Mem:       2071268    1163424     907844          0      93116     778288
-/+ buffers/cache:     292020    1779248
Swap:      4109304          0    4109304

comandos basicos Linux 2

comandos basicos Linux 3

 

 

JBOSS en Centos

CentOS JBOSS - VMware Workstation_2013-06-27_23-43-20

Hace algún tiempo había escuchado hablar a a algunos colegas sobre JBOSS la verdad nunca lo había utilizado ni sabía para que se utilizaba, esta conversación es la que  hoy me trae a este nuevos post.

Empecemos por dar une breve descripción de lo que es nuestro querido JBOSS. Este es un servicio o servidor de aplicaciones JAVA EE de código abierto por lo que lo hace muy versátil y puede ser utilizado, descargado y distribuido gracias a su licencia  LGPL que permite usarse libremente sin ningún costo en cualquier aplicación.

Características:

  • Opensource
  • Escalable
  • Alto desempeño
  • Licencia sin costo alguno
  • Arquitectura modular
  • Soporte para JMX
  • Servicios de middleware para cualquier objeto de JAVA.

Bueno no siendo más manos a la obra

  1. Validar versión instalada de JAVA en nuestro servidor. Si esta instalada debe devolver un mensaje como este.

#java -version

[root@localhost java]# java -version
java version “1.7.0_25”

2. Descargamos la ultima version de JBOSS con el siguiente comando a nivel de /usr/share/

[root@localhost bin]#wget http://download.jboss.org/jbossas/7.1/jboss-as-7.1.1.Final/jboss-as-7.1.1.Final.zip

3.  Se descomprime el JBOSS.

[root@localhost prueba]# unzip -q jboss-as-7.1.1.Final.zip

Nos debe que dar asi  al listar ls

[root@localhost prueba]# ls
jboss-as-7.1.1.Final  jboss-as-7.1.1.Final.zip

Eliminanos el archivo .ZIP
[root@localhost prueba]# rm -rf jboss-as-7.1.1.Final

Verificamos la ruta

[root@localhost jboss-6.0.0.final]# pwd
/usr/share/jboss-as-7.1.1.Final

4. Ahora crearemos el usuario y grupo para JBOSS

[root@localhost jboss-6.0.0.final]# groupadd jboss
[root@localhost jboss-6.0.0.final]# useradd -s /bin/bash -g jboss jboss

5. Cambiamos la propiedad del directorio para el usuario JBOSS

[root@localhost jboss-6.0.0.final]# chown -Rf jboss.jboss /usr/share/jboss-as-7.1.1.Final/

6. Configuramos los paths tanto de JAVA_HOME como de JBOSS_HOME para el usuario root y jboss.

Quedando de esta forma.

[root@localhost jboss-6.0.0.final]# nano /root/.bash_profile

JAVA_HOME=/usr/java/jdk1.7.0.25
export JAVA_HOME
PATH=$JAVA_HOME/bin:$PATH
export PATH
JBOSS_HOME=/usr/share/jboss-as-7.1.1.Fina
export JBOSS_HOME

7. Vamos a la ruta donde esta el jboss y nos ubicamos en bin

[root@localhost bin]# pwd
/usr/share/jboss-6.0.0.final/bin

8. Ejecutamos el comando de inicio del JBOSS (normalmente esta pantalla se quedara congelada)

[root@localhost bin]# ./standalone.sh
=========================================================================

JBoss Bootstrap Environment

JBOSS_HOME: /usr/share/jboss-6.0.0.final

JAVA: java

JAVA_OPTS:  -server -XX:+TieredCompilation -Xms64m -Xmx512m -XX:MaxPermSize=256m -Djava.net.preferIPv4Stack=true -Dorg.jboss.resolver.warning=true -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djboss.modules.system.pkgs=org.jboss.byteman -Djava.awt.headless=true -Djboss.server.default.config=standalone.xml

=========================================================================

22:20:56,287 INFO  [org.jboss.modules] JBoss Modules version 1.1.1.GA
22:20:56,770 INFO  [org.jboss.msc] JBoss MSC version 1.0.2.GA
22:20:56,883 INFO  [org.jboss.as] JBAS015899: JBoss AS 7.1.1.Final “Brontes” starting
22:21:03,428 INFO  [org.jboss.as.server] JBAS015888: Creating http management service using socket-binding (management-http)
22:21:03,577 INFO  [org.xnio] XNIO Version 3.0.3.GA
22:21:03,705 INFO  [org.xnio.nio] XNIO NIO Implementation Version 3.0.3.GA
22:21:03,718 INFO  [org.jboss.as.configadmin] JBAS016200: Activating ConfigAdmin Subsystem
22:21:03,746 INFO  [org.jboss.as.logging] JBAS011502: Removing bootstrap log handlers
22:21:03,811 INFO  [org.jboss.as.naming] (ServerService Thread Pool — 38) JBAS011800: Activating Naming Subsystem
22:21:03,831 INFO  [org.jboss.as.webservices] (ServerService Thread Pool — 48) JBAS015537: Activating WebServices Extension
22:21:03,800 INFO  [org.jboss.as.security] (ServerService Thread Pool — 44) JBAS013101: Activating Security Subsystem
22:21:03,964 INFO  [org.jboss.remoting] (MSC service thread 1-2) JBoss Remoting version 3.2.3.GA
22:21:04,247 INFO  [org.jboss.as.osgi] (ServerService Thread Pool — 39) JBAS011940: Activating OSGi Subsystem
22:21:04,278 INFO  [org.jboss.as.clustering.infinispan] (ServerService Thread Pool — 31) JBAS010280: Activating Infinispan subsystem.
22:21:05,284 INFO  [org.jboss.as.security] (MSC service thread 1-1) JBAS013100: Current PicketBox version=4.0.7.Final
22:21:05,303 INFO  [org.jboss.as.connector] (MSC service thread 1-2) JBAS010408: Starting JCA Subsystem (JBoss IronJacamar 1.0.9.Final)
22:21:06,158 INFO  [org.jboss.as.connector.subsystems.datasources] (ServerService Thread Pool — 27) JBAS010403: Deploying JDBC-compliant driver class org.h2.Driver (version 1.3)
22:21:06,197 INFO  [org.jboss.as.naming] (MSC service thread 1-2) JBAS011802: Starting Naming Service
22:21:08,353 INFO  [org.jboss.as.mail.extension] (MSC service thread 1-1) JBAS015400: Bound mail session [java:jboss/mail/Default]
22:21:09,049 INFO  [org.jboss.ws.common.management.AbstractServerConfig] (MSC service thread 1-2) JBoss Web Services – Stack CXF Server 4.0.2.GA
22:21:09,133 INFO  [org.apache.coyote.http11.Http11Protocol] (MSC service thread 1-1) Starting Coyote HTTP/1.1 on http–127.0.0.1-8080
22:21:09,994 INFO  [org.jboss.as.connector.subsystems.datasources] (MSC service thread 1-2) JBAS010400: Bound data source [java:jboss/datasources/ExampleDS]
22:21:10,475 INFO  [org.jboss.as.server.deployment.scanner] (MSC service thread 1-2) JBAS015012: Started FileSystemDeploymentService for directory /usr/share/jboss-6.0.0.final/standalone/deployments
22:21:10,513 INFO  [org.jboss.as.remoting] (MSC service thread 1-1) JBAS017100: Listening on /127.0.0.1:4447
22:21:10,515 INFO  [org.jboss.as.remoting] (MSC service thread 1-1) JBAS017100: Listening on /127.0.0.1:9999
22:21:11,005 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015951: Admin console listening on http://127.0.0.1:9990
22:21:11,006 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: JBoss AS 7.1.1.Final “Brontes” started in 15142ms – Started 133 of 208 services (74 services are passive or on-demand)

9. Validamos que este corriendo JAVA, la consola de administracion de nuestro JBOSS corre por el puerto 9990 y el servicio de tomcat correo por el puerto 8080.

[root@localhost jdk-7u25-linux-i586.bin]# netstat -apnl | grep java
tcp        0      0 127.0.0.1:9990              0.0.0.0:*                   LISTEN      11986/java
tcp        0      0 127.0.0.1:9999              0.0.0.0:*                   LISTEN      11986/java
tcp        0      0 127.0.0.1:8080              0.0.0.0:*                   LISTEN      11986/java
tcp        0      0 127.0.0.1:4447              0.0.0.0:*                   LISTEN      11986/java
unix  2      [ ]         STREAM     CONNECTED     128782 11986/java

10. Creamos el usuario para que pueda acceder a la consola de administracion de nuestro JBOSS

[root@localhost bin]# ./add-user.sh

What type of user do you wish to add?
a) Management User (mgmt-users.properties)
b) Application User (application-users.properties)
(a):

Enter the details of the new user to add.
Realm (ManagementRealm) :
Username : prueba
Password :
Re-enter Password :

* Error *
JBAS015238: Username must not match the password. (nos presenta este error por que el nombre y el password no pueden ser el mismo)

Comienza automaticamente la creacion del nueva poassword para el usuario.
Enter the details of the new user to add.
Realm (ManagementRealm) :
Username (prueba) :
Password :
Re-enter Password :
About to add user ‘prueba’ for realm ‘ManagementRealm’
Is this correct yes/no? y
Added user ‘prueba’ to file ‘/usr/share/jboss-6.0.0.final/standalone/configuration/mgmt-users.properties’
Added user ‘prueba’ to file ‘/usr/share/jboss-6.0.0.final/domain/configuration/mgmt-users.properties

Dice que fue creado con exito el user y password.

Validamos es mejor ser desconfiados😉

[root@localhost bin]# cat /usr/share/jboss-6.0.0.final/domain/configuration/mgmt-users.properties
#
# Properties declaration of users for the realm ‘ManagementRealm’ which is the default realm
# for new AS 7.1 installations. Further authentication mechanism can be configured
# as part of the <management /> in host.xml.
#
# Users can be added to this properties file at any time, updates after the server has started
# will be automatically detected.
#
# By default the properties realm expects the entries to be in the format: –
# username=HEX( MD5( username ‘:’ realm ‘:’ password))
#
# A utility script is provided which can be executed from the bin folder to add the users: –
# – Linux
#  bin/add-user.sh
#
# – Windows
#  bin\add-user.bat
#
# On start-up the server will also automatically add a user $local – this user is specifically
# for local tools running against this AS installation.
#
# The following illustrates how an admin user could be defined, this
# is for illustration only an does not correspond to a usable password.
#
#admin=2a0923285184943425d1f53ddd58ec7a
prueba=bebba8fb4a1a801b5210212e9993f565

10. Habilito acceso a la consola de administracion de JBOSS desde cualquier Rango o IP en el siguiente archivo, buscamos la siguiente linea y cambiamos el 127.0.0.1 por 0.0.0.0

[root@localhost java]# nano /usr/share/jboss-6.0.0.final/standalone/configuration/standalone.xml

<interfaces>
<interface name=”management”>
<inet-address value=”${jboss.bind.address.management:0.0.0.0}”/>
</interface>

11.  ingresaremos a la consola de alministracion por medio de el navegador http://localhost:9990

CentOS JBOSS - VMware Workstation_2013-06-28_00-40-14

Validamos ingreso por el puerto 8080 de tomcat

CentOS JBOSS - VMware Workstation_2013-06-28_00-42-50

12. Agregue estas dos lineas a las IPTABLES

[root@localhost bin] service iptables status

10   ACCEPT     tcp  —  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:8080
11   ACCEPT     tcp  —  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:9990

13. Validamos ingreso a la consola de administracion.

CentOS JBOSS - VMware Workstation_2013-06-28_00-58-16

Hay muchas mas opciones de configuraciones y optimizacion del servicio. Esta es una configuracion basica espero

les sea de utilidad.

Enlaces de referencia.

http://www.jboss.org/

http://es.wikipedia.org/wiki/JBoss

http://www.davidghedini.com/pg/entry/install_jboss_7_on_centos

Asegurando sshd en centos

El protocolo de comunicacion SSH a pesar de servirnos como conexión segura a nuestros servers no está a salvo de recibir unas cuantas visitas mal intencionadas por otras personas. Lo que debemos de tener presente que no hay nada seguro, lo único que haremos es optimizar un poco más la seguridad del servicio cambiando algunos parámetros de configuración.

Ingresamos a nuestro SRV  al servicio sshd y cambiaremos los parámetros con nuestro editor de preferencia.

#nano/etc/ssh/sshd_config

root@jbossetcrc1

Lo primero que haremos es cambiar el puerto por default que es el 22 por uno diferente a los puertos bien conocidos  para evitar conflictos con otros servicios, con esto tambien podremos evitar scripts que atacan directamente el puerto 22, por lo que el cambio de puerto es algo mas que opcional obligatorio. En nuestro caso colocamos el puerto 2224 y el protocolo version 2.

Port 2224

Seguidamente Buscamos la opcion Authentication

LoginGraceTime 2s: Esta opcion es el tiempo que se demora  la pantalla de login abierta a la espera de que el usuario se autentique Como sugerencia pueden ser menos de 20 segundos (20s).

PermitRootLogin no: como todos sabes por default en los S.O linux viene el usuario root. Este puede ser blanco de ataques directos por seguridad creamos un usuario estandar, despues de loguearnos con este usuario desconocido para todos podemos convertirnos en root por medio de su o sudo.

StrictModes yes: Forzar la comprobación de permisos en ficheros de claves y directorios.

MaxAuthTries 2:  Esta opcion es el numero de veces que nos podemos equivocar a la hora de ingresar la contraseña. Despues de el numero de intentos especficados se perdera la conexion. Evitando de esta forma ataques por intentos de conexion.

1

A nivel de atenticacion

Editamos las siguientes lineas.

SyslogFacility AUTH Especifica los registros de los eventos, esta opción esteficica el tipo de registro de se realiza en este caso AUTH, significa las autenticaciones que se hacen contra el servidor. Este parametro esta por default pero comentado #

LogLevel INFO Este parámetro vienen por defecto habilitado, se puede acceder a mas informacion en man sshd_config para saber mas del parámetro de los niveles de logueo.

1

X11Forwarding  Esta opción permite el uso de entornos graficos, puede ser muy util para utilizar algunas aplicaciones garficas de manera remota. Recuerda no habilitar cosas que no vas a utilizar.

Banner  Esta opción permite enseñar un carte de adventencia exponiendo las politicas y los riegos legales de accesos no autorizados. A la hora de intentar hacer logueo al servidor.

Esta opción la habilitamos en nuestro caso en la ruta /etc/ssh_banner.net donde especificamos lo que queremos que se muestre a la hora de intentar loguearse al servidor. En nuestro caso quedo de la siguiente manera.

Editar entrada ‹ Redes y Servidores — WordPress - Google Chrome_2013-06-24_17-40-52

Hay mas opciones de configuraciones del servicio ssh, estas son las mas básicas espero les sea de utilidad saludos,:)

Barcamp Security Edition v3

Es el evento descentralizado mas grande de seguridad de la informacion se reliza en 8 ciudades de colombia de forma simultanea, este proximo sabado se realizara  en su tercera version.

Sitio-Medellin

Fecha: 01 de Diciembre del 2012

Hora:  8:00-18:00

Lugar: Universidad Eatfit

Bloque 38, Auditorios 103 – 105

CARRERA 49 No 7 SUR – 50

Cupos: 300 personas    

Medellín - Barcamp 1

Programacion:

Medellín - Barcamp 2http://www.barcampse.org/